disco rigido esterno via USB con dentro vari OS … problemi

OS X, Linux e tutti gli altri OS

disco rigido esterno via USB con dentro vari OS … problemi

Messaggioda AMG_Novice_Usr » dom mag 02, 2021 8:47 am

Vi sottopongo una questione che sto affrontando in questi giorni.
Ho un disco rigido esterno della WD, da 1TB, collegabile al PC/Notebook via USB 3.0.
L’intenzione è quella di preparare questo HDD con una serie di partizioni, alcune di queste per data-storaging vario (backup per tempo libero, lavoro ecc …), altre partizioni invece le vorrei bootable, e dentro a quest’ultime ci voglio mettere alcuni OS, per lo più Windows e Lubuntu/GNU-Linux, poi magari potrei provare anche OS un po' più “amigosi”, Aros in primis …
La tabella delle partizioni è, di default, GUID Partition Table (GPT), ovvero lo standard de-facto da Win8 compreso in poi, e qui vi linko un articolino sintetico, ma abbastanza esaustivo, circa le differenze fra MBR e GPT (da inesperto, l’ho trovato istruttivo).

https://www.partizioni.com/differenza-t ... erabyte%20).

Ad ogni modo io ho trovato come tabella delle partizioni e bootloader limitrofo il formato GPT e non voglio (non avrebbe senso) effettuare un downgrade da GPT a MBR (qualora avessi trovato MBR, avrei fatto l’upgrade MBR -> GPT, dato che qualunque SW di partitions-management mette a disposizione una utility che consente di creare/rigenerare un GPT partendo da un MBR).
Qualora avessi in animo di avviare un OS vetusto, ad esempio WinXP, potrei andare nelle impostazioni dell’UEFI del mio PC e selezionare l’opzione “Legacy ON”, quindi attivazione dell’avvio in modalità “legacy”, ossia abilitazione del CSM (Modulo di Supporto alla Compatibilità): tale opzione consente al FW “UEFI” (correggetemi se sbaglio) di lavorare in modalità “BIOS”, quindi tramite il famoso interrupt di sistema IRQ 0x19 di cercare ed eseguire (dopo averlo copiato in RAM, all’indirizzo storico 0x00007C00) il bootloader contenuto nei primi 446 bytes dell’MBR, dove l’MBR (mi sembra di aver capito dal link di cui sopra) è mantenuto come primo LBA, primo blocco da 512 bytes (LBA-0) del ben più grande GPT, questo per consentire appunto ad un sistema x86 “vecchio”, quindi con un BIOS anziché un UEFI come FW di avvio, di lanciare un OS vetusto come Win2000, ME, XP ecc … da un HDD “moderno”, ovvero identificato/mappato dal GPT anziché dal semplice MBR.
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » dom mag 02, 2021 8:48 am

Ho pertanto preparato una partizione primaria da 512GB (metà dell’HDD) formattata in NTFS (ho preferito NTFS al FAT32 perché voglio prevedere delle cartelle con speciali diritti di accesso, user-sensitive … come sappiamo FAT32 non fornisce la possibilità di protezioni semplici in base all’utente o al gruppo, cosa invece normale per NTFS), e questa partizione la riservo appunto per i miei data-backups da ambienti sia Windows che GNU/Linux … fin qui, tutto liscio.
Adesso mi accingo a fare qualcosa che non avevo mai fatto prima (immagino che per uno smanettone qualunque, quanto sto per presentare costituisca pane quotidiano … io sto imparando, o meglio, ci sto provando, solo ora).
Ho realizzato diverse partizioni (una decina), ciascuna da circa 50GB, o comunque poche decine di GB, ciascuna delle quali dovrebbe ospitare una particolare installazione di OS che vorrei provare, installazioni eseguibili a partire da chiavette USB Live oppure da immagini .ISO che avevo di già, quindi in una di queste partizioni vorrei installare Lubuntu 20.04 LTS, in un’altra vorrei installare Win7-Pro, in un'altra WinXP, ecc …
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » dom mag 02, 2021 8:48 am

L’installazione di Lubuntu 20.04 LTS è andata subito bene.
Avevo già una chiavetta USB con dentro l’immagine Live di Lubuntu 20.04 LTS.
Ho pertanto avviato il PC con la chiavetta USB, ho bootato da questa chiavetta, ho quindi lanciato l’utility di installazione di Lubuntu, la quale mi ha consentito di plasmare 4 partizioni, che sono:
-una partizione di circa 20GB: file-system ext4 – punto di montaggio: /home
-una partizione di circa 15GB: file-system swap (credo che sia una specie di RAW) – punto di montaggio: sarebbe la swap-area di Lubuntu, l’equivalente del file “pagefile.sys” di Windows (che si trova in C: ) dove lo schedulatore a lungo termine salva le pagine dei processi, pagine che non vengono indirizzate spesso e/o che è da tanto tempo che non vengono indirizzate (Linux pare che richieda una partizione separata particolare, con un file-system particolare, da adibire a disk-storage per le pagine poco usate dei processi ready … qui si potrebbe aprire un topic dedicato!)
Avendo una RAM da 8GB, 16GB di swap-area vanno benone! Almeno, le buone pratiche di realizzazione della memoria virtuale (RAM fisica + swap-area) sono così soddisfatte.
-una partizione di circa 15GB: file-system FAT32 – punto di montaggio: /boot/efi – è la famosa partizione con flag ESP abilitato, ovvero partizione ESP, che sta per EFI Separated Partition, ovvero la partizione che contiene la tabella delle partizioni, in due copie, una copia chiamata “Primary GPT” ed una seconda copia di sicurezza/ridondanza (controllo CRC32) chiamata “Secondary GPT”, più il bootloader.
-una partizione di circa 67GB: file-system ext4 – punto di montaggio: / (la folder “root”)
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » dom mag 02, 2021 8:48 am

Se appena accendo il PC entro nell’UEFI-boot-options, e seleziono la voce “OS-boot ubuntu (UEFI)”, effettivamente viene avviato Lubuntu 20.04 LTS e tutto funziona come da manuale.
Su questo punto scatterebbe una prima domandina:
come mai, nonostante io abbia selezionato come boot-priority, la voce “USB-HDDs & pens” con maggiore priorità (la massima) nell’elenco, mentre invece la voce “SATA-inner HDD” con la priorità minore, all’avvio del PC, con HDD esterno collegato al PC via USB, il FW “UEFI”, sia in modalità vecchia “BIOS” (CSM “ON”) che in modalità normale/moderna “UEFI” (CSM “OFF”), non riesce ad avviare automaticamente Lubuntu installato sull’HDD-USB esterno, si avvia invece Win10 su SATA-HDD interno? Se voglio avviare Lubuntu, devo entrare nell’UEFI all’accensione del PC ed avviare manualmente il disco USB esterno con dentro Lubuntu … perché avviene questo?
Se richiesto/utile per voi, posso linkare foto delle schermate UEFI in questione …
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » dom mag 02, 2021 8:49 am

Ad ogni modo, riesco a lanciare Lubuntu … fin qui, tutto ok.
Quello che ancora non riesco a fare è di installare, su altre partizioni sull’HDD esterno USB, degli altri OS come ad esempio WinXP-64bit-english oppure Win7-Pro.
Di questi OSs ho le rispettive immagini .ISO, che monto su lettori ottici virtualizzati con Daemon Tool Lite versione free (questo SW gira sul mio PC fisico, su cui ho Win10 – Home edition).
Pertanto, dopo aver montato su lettore ottico virtuale la voluta .ISO, entro con esplora-risorse nel CD montato, lancio setup.exe, appare quindi la schermata di WinXP-64 piuttosto che di Win7.
Nel caso di WinXP-64, appare la schermata iniziale dell’installer, con la voce “Install XP” ingrigita, disabilitata, mentre io mi sarei aspettato che tale voce fosse cliccabile/eseguibile … invece no.
Le altre voci del menu invece sono abilitate, ma a me non interessato in questa fase …
Nel caso di Win7, la voce “Install” è abilitata.
Procedo quindi lungo tale wizard, durante la quale mi viene chiesto se voglio installare Win7 con oppure senza il supporto di internet, ed io ho provato entrambe le strade … stesso risultato (a cui sto per arrivare).
Clicco su “i agree” del contratto, e accedo quindi alla selezione della partizione su disco 0 oppure su disco 1 nella quale voglio installare Win7-Pro.
Il disco 0 è il disco interno via SATA, quello di sistema di default, del PC insomma, su cui gira Win10, e che non voglio toccare: non voglio aggiungere partizioni, non voglio neppure “sfiorare” la partizione di sistema EFI (o meglio detto, la partizione EFI-Separated-Partition, la partizione ESP in FAT32, che contiene la GPT). Questa ESP non la voglio neppure “grubbare”, cioè non voglio metterci il bootloader grub di Lubuntu, e infatti la partizione EFI (ESP) FAT32 di sistema, per far avviare Lubuntu, l’ho messa nel disco 1, cioè nel disco esterno USB, dato che il disco 0 SATA interno non lo vorrei toccare, deve restare così com’è, per ragioni di sicurezza.
Dicevo, adesso seleziono una partizione (come detto prima, ne ho diverse) sul disco 1 esterno via USB, sulla quale voglio installare Win7-Pro, di cui sto eseguendo la wizard dell’installer … ebbene, qui nasce il bus-illis: appena seleziono su questa partizione, ed in generale su qualunque partizione del disco 1 USB, l’installer di Win7 mi dice che “Windows non può essere installato su quella partizione”.
Motivo:
l’installer dentro la .ISO di Win7 non ha il driver dell’HUB USB 3.0 (se richiesto/utile, posso mandare screeshots, così da farvi vedere il messaggio nella sua esattezza), insomma manca il driver che consentirebbe all’installer di Win7 che sto eseguendo di vedere correttamente il disco esterno via USB.
Altra possibilità paventata dall’installer, è che quel particolare disco non è utilizzabile in questo modo (tendo più a credere al primo punto … voi che ne pensate?).
Altra possibilità, è che il FW UEFI non sia impostato in modalità di compatibilità, stile BIOS/x86.
Quest’ultima possibilità l’ho risolta da quando ho selezionato in UEFI l’opzione “legacy ON”, quindi da quando ho abilitato il CSM.
E infatti la terza possibilità non me l’ha più data, quindi rimangono le prime due … io credo che sia la prima!
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » dom mag 02, 2021 8:49 am

Ho quindi provato a caricare dall’installer di Win7-Pro il driver “USBSTOR.SYS”, che si trova in C: Windows\System32\drivers.
Il selettore dell’installer mi consente di navigare lungo suddetto path e di arrivare fino alla cartella “drivers”, ma a questo punto non mi consente di selezionare selettivamente il file “USBSTOR.SYS”, quindi io seleziono tutta la cartella “drivers” … il risultato è questo:
“windows non può caricare la cartella poiché questa non contiene drivers firmati/riconoscibili dall’installer di Windows”.
Al solito, se utile posso postare lo screeshot con il messaggio esatto, ma la sostanza è quella che vi ho detto qui.
Ho provato anche a lanciare setup.exe da CD-ROM fisico, poiché lo possiedo, CD da cui ho ricavato il file .ISO, così da fugare i dubbi circa il corretto funzionamento del montaggio virtuale delle .ISO tramite Daemon Tool Lite: stesso problema di prima, pertanto Daemon non era il problema, lo fa anche da CD fisico.
Come posso risolvere la cosa? Ovvero installare un Windows (XP, 7, ecc …) su una partizione nell’HDD esterno via USB?
Cosa sto sbagliando?
Grazie!
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMIGASYSTEM » dom mag 02, 2021 9:02 am

Attenzione Windows non può essere installato su disco esterno o pennina, salvo tu non utilizzi le versioni "Enterprise" di Wi7/8/10 che incudono uno strumento apposito chiamato "WindowsToGo".

Per XP esiste una procedura da smanettatori che io ho utilizzato ma oltre ad essere complicata non era il massimo della funzionalità.

Riguardo AROS attenzione perchè se lo installi normalmente ti piallerà tutte le partizioni, per installare AROS in DualBoot con altri OS, una volta installati gli altri OS bisogna lasciare una partizione grezza "vergine" in qualsiasi posizione.

Fatto questo AROS riconoscerà quella partizione come suo Disco e si prenderà la massima grandezza supportata lasciando il resto della partizione disponibile per altri scopi, magari na partizione i FAT32 per condividere i dati, AROS supporta NTFS in sola lettura.

Per AROS consiglio come prima volta un HD dedicato o una pendrive, AROS può essere installato anche da una immagine HD USB naturalmente opzione valida solo per le distribuzioni AROS One e Icaros.
Immagine - AROS One Home Site - AfA One - AROS One x86 - AROS One 68K - WinUAE OS 4.1 -

Miei AMIGA
Amiga 4000/Cyberstorm MK II/060/Picasso RAM 6MB Kick 3.1
Amiga 1200/030 Ram 16 Mega HD 500 MB
Amiga 1200/040 Ram 32 Mega HD 500 MB
Amiga 600 HD 20 MB
Amiga 600 Doppio Kickstart 2.05-1.3
Amiga 500 Plus Doppio Kickstart 204-1.3
Amiga 500
CD32/SX-32 MK1 RAM 8 MB HD 4G
CD32 Standard
Avatar utente
AMIGASYSTEM

Staff
 
Messaggi: 5510
Iscritto il: ven lug 25, 2008 8:39 pm
Località: Brindisi

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda Seiya » dom mag 02, 2021 1:04 pm

AMG_Novice_Usr ha scritto:V
Ho un disco rigido esterno della WD, da 1TB, collegabile al PC/Notebook via USB 3.0.



Io ho Linux su un HD esterno e funziona in questo modo:

Se accendi il computer lui carica Windows o un altro OS installato su una porta SATA o IDE. Linux lo devi scegliere manutalmente con il tasto F8 o F2 o un tasto del tuo bios UEFI.
Se tu riavvi linux da HD esterno, allora il sistema da la priorità all'HD USB, ti carica il grub da cui tu puoi scewgliere se caricare Linux o Windows (di default è linux).

Se spegni l'HD esterno durante il riavvio perchè vuoi risparmiare corrente e non vuoi spegnere e accedere il computer, allora succede che il bios non trova l'HD esterno e non trova nemmeno più HD con Windows perchè ha cambiato la priorità. Nel mio caso facendo così il mio bios sposta l'HD con Windows nell'ultima posizione della lista di avvio e come primo HD ne mette un altro che forse ha un ID subito successivo a quello che aveva quello esterno.

Niente di grave perchè dal setup del bios rimetti tutto nel giusto ordine.

Se tu hai l'HD esterno acceso e accendi il PC credo che carica Windows automaticamente qualunque tu imposti. Alle volte succede che durante il post del bios l'HD esterno USB pur riconosciuto dal bios non sia pronto all'avvio (il motorino è lento ad avviarsi, il bios è impostato per avviare il primo OS su SATA o HD dopo un tot secondi).
Alle volte succede che il bios si blocca quando fa un detect dell'HD usb esterno. Lo vede, ma non riesce a superare il post e rimane bloccato li.

Per questo che è la priorità meglio non metterla mai su un HD esterno.
Seiya

Supremo
 
Messaggi: 3653
Iscritto il: sab lug 04, 2009 11:22 pm

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » lun mag 03, 2021 10:41 pm

Io ho Linux su un HD esterno e funziona in questo modo:
Se accendi il computer lui carica Windows o un altro OS installato su una porta SATA o IDE. Linux lo devi scegliere manutalmente con il tasto F8 o F2 o un tasto del tuo bios UEFI.


Confermo che anche a me succede questo, però ti dico la verità: non mi torna molto.

Breve ricapitolazione di quanto ho capito finora sul bootstrap di un PC (correggete se sbaglio):

Appena accendiamo il PC, viene eseguito il FW di avvio, BIOS oppure UEFI. Tale FW viene eseguito non da tutte e 4 le CPU del mio Intel i5, bensì soltanto da una di queste 4 CPU, ovvero dalla CPU “BSP”, ossia dal BootStrap (BS) Processor (P), le altre 3 CPUs invece non vengono coinvolte in questa fase iniziale, queste 3 CPUs momentaneamente sono inattive e vengono identificate come le "AP," ovvero Application Processors.

Con i BIOS funziona così (con UEFI?), solo una CPU “BSP” esegue appunto il BIOS, il sotto-programma di POST ecc … le altre CPU “AP” subentrano solo quando viene caricato il kernel di un OS, quindi alle battute finali (non ho ancora capito come viene scelta una CPU, fra le 4 disponibili nel mio Intel i5, in qualità di BSP: quale criterio viene seguito affinchè si possa dire che la CPU 1 è la “BSP” mentre le CPU 2,3,4 sono “AP”?? Online ho letto che la BSP, fra le 4 CPU di un quad-core, viene scelta “dinamicamente” … esattamente avete idea di come funzioni la cosa?).

Ad ogni modo, torniamo sui binari …

La CPU “BSP” esegue il BIOS, per cui viene eseguita prima l’inizializzazione minimale dell’HW, poi il POST, quindi il self-test di base dell’HW appena inizializzato: credo che una delle prime cose che dovrebbero essere inizializzate è il chip di RAM (es: DDR3), poiché se questo chip supera anche la fase di POST, allora la parte rimanente di BIOS/UEFI ancora non indirizzata/eseguita dalla BSP può essere copiata dal chip di ROM/Flash, in cui risiede tale FW, al chip di RAM appunto, quindi le fasi finali del BIOS/UEFI potrebbero essere indirizzate ed eseguite in RAM (come avviene per un normale programma).

Ovviamente il BIOS/UEFI viene eseguito in modalità "real-mode", quindi spazio di indirizzamento lineare, non segmentato, niente paging, quindi niente MMU: accesso diretto/semplice alla flash/ram (nel BIOS dovremmo avere lo spazio di indirizzamento su 20 bits, quindi 1MB di range spaziabile ... con UEFI forse no? ... non so).

Una volta che il POST è superato per tutto l’HW della scheda madre del PC, quindi una volta che anche le porte come la IDE, la PATA, la SATA, le porte USB … sottolineo “tutto l’HW”, tutte le interfacce sono state configurate e testate dal POST, a questo punto il BIOS/UEFI dovrebbe fare uno scanning di tutte le interfacce per memorie di massa, per valutare se esiste un supporto di memorizzazione di massa che contenga almeno una partizione/volume bootable.

L’ordine di tale scansione dovrebbe seguire l’ordinamento, in base alle priorità, imposto da me, quando sono entrato del BIOS/UEFI l’ultima volta (ho acceduto a UEFI, ho settato queste priorità, ed ho salvato). Io ho impostato le priorità in modo che prima ci siano pennette flash e HDD via USB, poi dischi ottici CD/DVD, e come minimo livello di priorità ho messo la voce “OS boot manager IDE/SATA HDD”.

Quindi il BIOS/UEFI dovrebbe seguire questo ordine di scanning, vedere che esiste un HDD esterno su una porta USB, e a quel punto UEFI dovrebbe valutare la partizione di sistema EFI (FAT32) presente in questo disco, eseguirne il bootloader-code e leggerne la tabella GPT, la quale rimanderebbe alle partizioni di home (ext4), root (ext4) e swap (swap) che ho creato per installare manualmente Lubuntu su questo HDD esterno.

Invece il disco esterno USB viene ignorato ed il check da parte di UEFI arriva subito alla porta SATA, sulla quale ho un disco interno, con tanto di sua partizione di sistema EFI, sua GPT, e sua partizione di avvio C: nella quale ho Win10, e si avvia Win10.

Il mio dubbio è che ci sia, a questo punto, un problema nel POST del bios F.21 by Insyde: può darsi che la routine di POST inizializzi solo di base, diciamo in modo “non completo”, le porte USB del PC, quindi a fine POST, quando il BIOS/UEFI scansione le interfacce per vedere se c’è un disco avviabile, non riesce a vedere il disco esterno via USB, quindi lo scanning ricade sulla porta SATA, che invece è a posto, da cui l’avvio di Win10 … può essere?
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » lun mag 03, 2021 10:49 pm

Se tu riavvi linux da HD esterno, allora il sistema da la priorità all'HD USB, ti carica il grub da cui tu puoi scewgliere se caricare Linux o Windows (di default è linux).


A me questo aspetto non funziona così (l’ho verificato).

Vediamo cosa faccio:

-Primo step:

avvio manualmente il boot da HDD esterno via USB.
Vedo che viene eseguito il grub, che mi da una selezione di avvio (di default è selezionato Lubuntu, come prima voce), pertanto o premo enter su Lubuntu, oppure faccio scadere il timeout, fatto sta che lancio Lubuntu.

-Secondo step:

adesso che Lubuntu è lanciato (sono nel desktop di Lubuntu), riavvio il PC.

-Terzo step:

il PC riavviato presenta lo stesso comportamento di prima, quindi il disco esterno USB viene ignorato, viene rilevato solo quello SATA interno, quindi viene avviato Win10, e non Lubuntu!

Del resto, mi aspettavo questo comportamento: perché riavviando il PC da Lubuntu, avrei dovuto avere un diverso comportamento del sistema nei confronti dei dischi esterni collegati alle porte USB? Quando riavvi, non hai priorità diverse, o "capacità" diverse, dovute all’OS dal quale hai riavviato: le priorità di booting sono legate ai settaggi del BIOS/UEFI (settaggi che si dovrebbero trovare nella RAM “CMOS” tamponata da batteria … giusto?), quindi non dipendono dall’OS da cui hai riavviato.
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » lun mag 03, 2021 10:57 pm

Se tu hai l'HD esterno acceso e accendi il PC credo che carica Windows automaticamente qualunque tu imposti.


Credo che carichi automaticamente l’OS che si trova su IDE/SATA, quindi un volume avviabile che si trova nell’HDD interno, qualunque sia l’OS in questo volume (non solo Windows). Secondo me è perché in fase di POST le porte USB non vengono inizializzate/testate nel modo migliore, quindi eventuali HDD esterni/accesi, connessi al PC via USB, non vengono presi in considerazione dal BIOS, quando lui cerca i dischi, per trovare un volume avviabile.

Alle volte succede che durante il post del bios l'HD esterno USB pur riconosciuto dal bios non sia pronto all'avvio (il motorino è lento ad avviarsi, il bios è impostato per avviare il primo OS su SATA o HD dopo un tot secondi).


Un motorino DC brushless o brushed (chissà che motore di spinning abbiamo nei dischi di oggi?), dopo lo spunto, diciamo che in 200/300ms al massimo è a regime, e dubito che il BIOS/UEFI tenti di cercare la partizione EFI oppure il semplice MBR sul disco esterno in USB prima di qualche secondo dall’accensione della macchina … sbaglio?

Ad ogni modo, potrebbe essere che per motivi elettrici il disco esterno all’inizio non sia compiacente, quindi scade il timeout, scaduto il quale il BIOS/UEFI va a cercare MBR/partizione EFI sui bus interni (IDE, SATA, ecc …).
Lì magari non ci sono timeout, oppure sono molto maggiori, chissà: il motorino che troviamo nel disco esterno in USB è uguale a quello del disco interno su SATA.
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMG_Novice_Usr » lun mag 03, 2021 11:02 pm

Alle volte succede che il bios si blocca quando fa un detect dell'HD usb esterno. Lo vede, ma non riesce a superare il post e rimane bloccato li.


Per adesso non mi è successo, per fortuna.

Ma non ci dovrebbe essere il timeout? Se diciamo entro 1 secondo, il POST non termina con successo la procedura di self-test sull’hub USB, dovrebbe uscire e continuare con il test di altre interfacce ... no? Alla fine della fiera sarebbe controproducente far piantare il POST, quindi il boot del PC, solo perché ci sono problemi con un device collegato ad una USB, che non è fondamentale ai fini dell’utilizzo del PC.
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda Seiya » mar mag 04, 2021 3:00 am

AMG_Novice_Usr ha scritto:Del resto, mi aspettavo questo comportamento: perché riavviando il PC da Lubuntu, avrei dovuto avere un diverso comportamento del sistema nei confronti dei dischi esterni collegati alle porte USB?


se per caso hai più HD USB, prova a spegnerli e lasciare solo quello con linux e da linux fai un ravvio e vedi un po' cosa succede.

AMG_Novice_Usr ha scritto:Ma non ci dovrebbe essere il timeout? Se diciamo entro 1 secondo, il POST non termina con successo la procedura di self-test sull’hub USB, dovrebbe uscire e continuare con il test di altre interfacce ... no? Alla fine della fiera sarebbe controproducente far piantare il POST, quindi il boot del PC, solo perché ci sono problemi con un device collegato ad una USB, che non è fondamentale ai fini dell’utilizzo del PC.


io mio computer dove uso linux è vecchio: Asus P5Q e Q9950, quindi un bios abbastanza vecchio e ha sempre avuto qualche problema. Funziona bene, ma io non posso riavviare dal pulsante perchè se lo faccio si spegne il computer, poi si riavvia da solo e alle volte si resetta totalmente il bios.E' un bios che si comporta come se va in protezione.
E quindi con certi OS da USB che non hanno una procedura regolare di riavvio, devo spegnere la macchina. Se si pianta Linux deve spegnere, ma facendo così alle volte quando riaccendi gli HD USB che hanno un OS e un grub il bios non li vede più e non li vede anche dopo diversi spegnimenti e accensioni. Il computer va spento, aspettare qualche secondo.

Questo problema lo fa solo con gli OS alternativi su USB.
Seiya

Supremo
 
Messaggi: 3653
Iscritto il: sab lug 04, 2009 11:22 pm

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda AMIGASYSTEM » mar mag 04, 2021 8:25 am

Se ne Bios esiste un Boot Menu o la possibilità di memorizzare la periiferica d'avvio l'HD esterno o la pennina può avere la precedenza su tutto.

Se è sfuggito quanto da me riportato sopra, i sistemi Windows non possono essere avviati da HD Esterno salvo non si abbia una versione "Enterprise" di Win7/8/10 che incudono uno strumento apposito chiamato "WindowsToGo", per XP esiste una procedura non ufficiale fatta da un utente windows.
Immagine - AROS One Home Site - AfA One - AROS One x86 - AROS One 68K - WinUAE OS 4.1 -

Miei AMIGA
Amiga 4000/Cyberstorm MK II/060/Picasso RAM 6MB Kick 3.1
Amiga 1200/030 Ram 16 Mega HD 500 MB
Amiga 1200/040 Ram 32 Mega HD 500 MB
Amiga 600 HD 20 MB
Amiga 600 Doppio Kickstart 2.05-1.3
Amiga 500 Plus Doppio Kickstart 204-1.3
Amiga 500
CD32/SX-32 MK1 RAM 8 MB HD 4G
CD32 Standard
Avatar utente
AMIGASYSTEM

Staff
 
Messaggi: 5510
Iscritto il: ven lug 25, 2008 8:39 pm
Località: Brindisi

Re: disco rigido esterno via USB con dentro vari OS … proble

Messaggioda Seiya » mar mag 04, 2021 1:52 pm

Il bios lo fa da solo. auto imposta un HD esterno come priorità durante i vari reset software sia da linux che da windows. Se spegni la macchina, il bios cambia di nuovo la priorità e la mette su un HD SATA con ID successivametne dopo quello USB. Il mio HD SATA con Windows viene messo come ultimo della lista anche se nel bios è salvato come il primo della lista.

Lo fa solo con Linux. con AROS non lo fa.

Non so come funziona un bios per queste cose. Può darsi che in presenza di Linux e Windows il bios si auto adatta e modifica delle impostazione in automatico: ho 5 HD interni e quello con Windows è il primo della lista. Quando attivo l'unita USB con linux e riavvio da quest'ultimo, l'HD con Windows automaticamente viene salvato come ultimo della lista di avvio. (Nel bios io ho impostato solo 2 unita di avvio: CD-ROM e Windows, ma poi diventa CD-ROM e linux con reset software e dopo lo spegnimento diventa CD-ROM e HD senza OS).

La prossima volta faccio un'altra prova: accendo l'hd usb e da bios lo importo come priorità e vedo come si comporta con un riavvio e dopo uno spegnimento del PC.
Seiya

Supremo
 
Messaggi: 3653
Iscritto il: sab lug 04, 2009 11:22 pm

Prossimo

Torna a Altri sistemi operativi

Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti