FastFileSystem per OS 2.04 da aggiornare con LoadModule

Riflessioni, eventi, curiosità

FastFileSystem per OS 2.04 da aggiornare con LoadModule

Messaggioda AMG_Novice_Usr » lun apr 05, 2021 7:01 pm

Buonasera,

sapete quale è la versione di FFS più aggiornato per l'OS 2.04?

Ho un A500-Plus con HDD-SCSI, su cui ho istallato l'OS 2.04.

L'installazione su HDD è stata eseguita dal floppy Install 2.04, con il supporto degli altri 3 floppies:

WB 2.04
Extras 2.04
Fonts 2.04

Il floppy "Superkickstart" ovviamente non si è reso necessario, dal momento che la wizard di installazione ha già trovato, durante il suo lavoro, il kickstart 2.04 residente in chip-ram.

A fine installazione, il requester (lo standard-output su CLI/Shell) mi comunica che nel path:

Sys: L

è stato messo il file:

FastFileSystem

ovvero il file descrittore di una nuova/più avanzata versione di FFS.

La stessa wizard consiglia di customizzare la startup-sequence in modo da caricare in chip-ram questo nuovo FFS, sovrascrivendo appunto questa nuova versione sulla vecchia (vecchia = quella nativa, caricata cioè dal chip-ROM kick).

La motivazione che adduce la wizard è questa:

caricando questo nuovo FFS, otterremo un risparmio in termini di utilizzo di chip-ram (bello!).

Dunque mi precipito a customizzare la mia user-startup, aggiungendo questa riga:

LoadModule L:FastFileSystem noreboot

ovviamente "LoadModule" l'ho preso da Aminet e posizionato in Sys: C.

Durante il boot di Amiga, il prompt dice:

"Filesystem version 37 already resident.
Loading filesystem failed: object already exists."

In definitiva la mia domanda è:

esiste una versione di FFS per OS2.04 superiore, che possa essere caricata con LoadModule?

grazie!
Avatar utente
AMG_Novice_Usr

Veterano
 
Messaggi: 271
Iscritto il: ven mag 01, 2020 10:10 am
Località: Pisa

Re: FastFileSystem per OS 2.04 da aggiornare con LoadModule

Messaggioda AMIGASYSTEM » lun apr 05, 2021 9:49 pm

Scusa a che ti serve quel comando con LoadModule? il File FastFileSystem come avrai notato esiste solo nel floppy Install, questo ti fa capire che serve solo quando si creano le partizioni, fatto questo quel file non è più necessario.

Se vuoi aggiornare FFS sul tuo Hardisk devi impostarlo durante la creazione delle partizioni, la procedura è la stessa che utilizzi quando installai un Filesystem diverso come PFS o SFS !

OS 2.04 dovrebbe supportare senza problemi anche le versioni FFS di OS3
Immagine - AROS One Home Site - AfA One - AROS One x86 - AROS One 68K - WinUAE OS 4.1 -

Miei AMIGA
Amiga 4000/Cyberstorm MK II/060/Picasso RAM 6MB Kick 3.1
Amiga 1200/030 Ram 16 Mega HD 500 MB
Amiga 1200/040 Ram 32 Mega HD 500 MB
Amiga 600 HD 20 MB
Amiga 600 Doppio Kickstart 2.05-1.3
Amiga 500 Plus Doppio Kickstart 204-1.3
Amiga 500
CD32/SX-32 MK1 RAM 8 MB HD 4G
CD32 Standard
Avatar utente
AMIGASYSTEM

Staff
 
Messaggi: 5509
Iscritto il: ven lug 25, 2008 8:39 pm
Località: Brindisi


Torna a Amiga in generale

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti

cron